INF-USB2 and SI-USB
Operation Manual
15-157 REV G
10/31/2012
Contents

1 Contents .......................................................................................................................... 2

2 Trademarks ................................................................................................................... 3

3 Remarks .......................................................................................................................... 3

3.1 License Terms for Interface Software ........................................................................ 3

3.2 Intended Use .................................................................................................................. 3

3.3 System Requirements ................................................................................................. 3

3.4 Driver and Software Installation .................................................................................. 4

4 Hardware ....................................................................................................................... 4

4.1 Hardware description ................................................................................................. 4

4.2 Wiring Diagram .......................................................................................................... 5

4.3 Pin Assignment for Strain Gauge Sensors with mV signal ........................................ 5

4.4 Pin Assignment for Active Sensors with +/-5V signal ................................................ 5

4.5 Pin Assignment for Active Sensors with 0-20ma signal .............................................. 5

5 Starting the Software .................................................................................................... 6

6 Description of the Operating Mode ............................................................................... 6

6.1 The Menu Bar/Navigation Bar of the Program ............................................................ 7

6.1.1 File → Save Measvalue (Shortcut „Ctrl+M”) .......................................................... 7

6.1.2 File → Save Diagram (Shortcut „Ctrl+D”) ............................................................. 7

6.1.3 File → Print (Shortcut „Ctrl+P”) ............................................................................ 8

6.1.4 File → Exit (Shortcut „Ctrl+E”) ............................................................................ 8

6.1.5 Operating Mode ..................................................................................................... 8

6.1.6 View ....................................................................................................................... 9

6.1.7 Language ............................................................................................................... 8

6.1.8 Help → Info ........................................................................................................... 8

6.1.9 Help → Advice ...................................................................................................... 9

6.2 Configuration Mode ................................................................................................... 10

6.2.1 Sensor Connection ............................................................................................... 10

6.2.1.1 Sensor Connection → Baud Rate .................................................................... 11

6.2.1.2 Sensor Connection → Update ..................................................................... 11

6.2.2 Sensor Information ............................................................................................... 12

6.2.2.1 Sensor Information → General .................................................................... 12

6.2.2.2 Sensor Information → Channel A/B ............................................................. 12

6.2.3 Measurement Adjust. ............................................................................................ 13

6.2.3.1 Measurement Adjustments → Measured variable → Type ................................. 13

6.2.3.2 Measure Adjust. → Measured variable → Sampling Rate ................................. 14

6.2.3.3 Measure Adjust. → Measured variable → Display ........................................ 14

6.2.3.4 Measure Adjust. → Diagram ......................................................................... 15

6.2.3.5 Measure Adjust. → Trigger ............................................................................ 16

6.2.3.5.1 Trigger ..................................................................................................... 17

6.2.3.5.2 Diagram Example .................................................................................... 18

6.2.3.5.3 Hysteresis ............................................................................................... 18

6.2.4 Documentation ...................................................................................................... 18

6.2.4.1 Documentation → Output Measured Values ................................................... 19

6.2.4.2 Documentation → Output Diagram ................................................................ 20

6.2.4.3 Documentation → Additional Information ..................................................... 20

6.2.5 Sensor Adjustment ............................................................................................... 21

6.3 Meas./Diagram Mode .................................................................................................. 22

7 Debugging .................................................................................................................... 24
2 Trademarks
Windows® and Excel® are either registered trademarks or registered brands and brands of the Microsoft Corp. (according to the State Law of Washington), Redmond, Wash., US and/or other countries. All trademarks or brands used in this document refer only to the respective product or the holder of the trademark or brand. Interface Inc., does not raise claims to other than its own trademarks or brands.

3 Remarks
This manual describes the installation under Windows 2000, XP, Vista and Windows 7.

Please note that Windows requires administrator rights for the installation of drivers!
Please speak to your administrator if you do not have those rights!

3.1 License Terms for Interface Software
The copyrights for this software remain at:
Interface Inc., 7401 E. Butherus Dr. Scottsdale, AZ 85260 United States  www.interfaceforce.com

During the software installation, the license conditions will be displayed and must be accepted, otherwise the installation will be aborted. After the installation, the license conditions can be viewed in menu ‘Help → Advice’.

3.2 Intended Use
The INF-USB2-VS software was designed for the adjustment, control and read-out of the INF-USB2 and SI-USB. Further functions of the INF-USB2-VS software are reception, display and storing of measured values. Any use beyond this is considered as not intended.

3.3 System Requirements
The operation of INF-USB2 software requires a PC with the following system conditions:
• Windows 2000, Windows XP, Windows Vista or Windows 7
• USB-Interface for the connection of the INF-USB2 or the SI-USB
• Maximum of two monitors will be supported

Recommended Hardware Requirements:
• Application process without diagram Single-Core from 2.0 GHz
• Application process with diagram Dual-Core from 1.8 GHz
• The higher the sampling rate and the longer a measurement lasts, the higher the required main storage should be. The measurement ends as soon as the system does not provide any more free main storage space. The absolute size of the main storage is dependent on the operating system and the components installed.
3.4 Driver and Software Installation

Please refer to the document INF-USB2_SI-USB Quick-Start Guide, available on the PDFs/Downloads tab of the INF-USB2 product page at www.interfaceforce.com

4.1 Hardware Description

The INF-USB2 is a single-channel measurement amplifier for the conversion of analog signals into digital measured values.

The INF-USB2 power is supplied from the USB port. No external power supply is needed.

The INF-USB2 is designed for 3 types of sensor signals (specifications see datasheet):

- strain gauge signals: ±4.5mV/V (corresponding to ±30000 Digits)
- active signals with voltage input: ±5V (corresponding to ±25000 Digits)
- active signals with current input: 0 .. 20mA (corresponding to 0 .. +20000 Digits)

The SI-USB is a two-channel version of the INF-USB2. A provided external power supply is required. Data on the two channels is synchronized.

The SI-USB is designed for 4 types of sensor signals (specification see data sheet):

- strain gauge signals: ±4.5mV/V (corresponding to ±30000 Digits)
- strain gauge signals: ±3.0mV/V (corresponding to ±30000 Digits)
- active signals with voltage input: ±5V (corresponding to ±25000 Digits)
- active signals with current input: 0 .. 20mA (corresponding to 0 .. +20000 Digits)

The amplifier type and the resolution are listed on the type label and cannot be changed. Therefore only the corresponding sensor type may be connected.

The measuring data are signed in integer format (see above in brackets).

If the INF-USB2 is calibrated together with the sensor the output values will be listed on the test certificate.

If the INF-USB2 is calibrated without a sensor then the output values are as described above in brackets. They are pre calibrated with a high precision source.

The measuring data can be analyzed with the INF-USB2-VS Software. This software supports the following functions:

- Configuration of the INF-USB2 and SI-USB
- Storage of sensor-related scaling and adjustment data
- Displayed data (actual value, tare value, min value and max value)
- Presentation of the measured data in a diagram
- Storage of measured data in CSV-format (output configurable)
- Storage of the diagram in BMP-format (output size adjustable)
- Print-out of the diagram (output size defined)
- Presentation of the sensor information
4.2 Wiring Diagram INF-USB2

4.3 Pin Assignment for Strain Gauge Sensors with mV Signal

<table>
<thead>
<tr>
<th>Description</th>
<th>Pin (6 pole socket)</th>
<th>Color</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 V / GND</td>
<td>1</td>
<td>green</td>
<td>Ground of Supply voltage 4 V and 12 V</td>
</tr>
<tr>
<td>4 V</td>
<td>2</td>
<td>brown</td>
<td>Supply for strain gauge sensors 4 V</td>
</tr>
<tr>
<td>Signal +</td>
<td>3</td>
<td>yellow</td>
<td>positive signal input</td>
</tr>
<tr>
<td>Signal –</td>
<td>4</td>
<td>white</td>
<td>negative signal input</td>
</tr>
<tr>
<td>Control</td>
<td>5</td>
<td>grey</td>
<td>if available in sensor</td>
</tr>
<tr>
<td>Shield</td>
<td>6</td>
<td>shielding</td>
<td>do not connect shield with sensor housing</td>
</tr>
</tbody>
</table>

4.4 Pin Assignment for Active Sensors with ±5V Signal

<table>
<thead>
<tr>
<th>Description</th>
<th>Pin (12 pole socket)</th>
<th>Color</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 V / GND</td>
<td>E</td>
<td>green</td>
<td>Ground of Supply voltage 4 V and 12 V</td>
</tr>
<tr>
<td>Supply for</td>
<td>F</td>
<td>brown</td>
<td>active sensors 12 V</td>
</tr>
<tr>
<td>Signal +</td>
<td>C</td>
<td>yellow</td>
<td>signal input</td>
</tr>
<tr>
<td>Signal –</td>
<td>D</td>
<td>white</td>
<td>relating to signal input (internal to 0V / GND)</td>
</tr>
<tr>
<td>Control</td>
<td>K</td>
<td>grey</td>
<td>if available in sensor</td>
</tr>
<tr>
<td>Shield</td>
<td>M</td>
<td>shielding</td>
<td>do not connect shield with sensor housing</td>
</tr>
</tbody>
</table>

4.5 Pin Assignment for Active Current Sensors with 0.. +20mA Signal

<table>
<thead>
<tr>
<th>Description</th>
<th>Pin (12 pole socket)</th>
<th>Color</th>
<th>Remark</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 V / GND</td>
<td>E</td>
<td>green</td>
<td>Ground of Supply voltage 4 V and 12 V</td>
</tr>
<tr>
<td>Supply for</td>
<td>F</td>
<td>brown</td>
<td>active sensors 12 V</td>
</tr>
<tr>
<td>Signal +</td>
<td>C</td>
<td>yellow</td>
<td>signal input</td>
</tr>
<tr>
<td>Signal –</td>
<td>D</td>
<td>white</td>
<td>relating to signal input (internal to 0V / GND)</td>
</tr>
<tr>
<td>Control</td>
<td>K</td>
<td>grey</td>
<td>if available in sensor</td>
</tr>
<tr>
<td>Shield</td>
<td>M</td>
<td>shielding</td>
<td>do not connect shield with sensor housing</td>
</tr>
</tbody>
</table>
5 Starting the Software

The software starts only if it identifies a compatible sensor at the USB connection. After starting the executable file, the search for a compatible USB sensor is displayed. If the search is unsuccessful, check whether the USB circuit at the sensor is connected to the PC and whether the USB drivers have been installed. Then click on ‘Search again’ to restart the search for a compatible sensor. If a compatible sensor was found, the sensor-related data will be read-out automatically.

6 Description of the Operating Mode

The software consists of a menu bar, navigation bar, status bar and a workspace. The functions of the menu bar comply with the navigation bar. The digital displays of the physical values and the diagram can be seen under ‘Operating Mode → Meas./Diagram Mode’. In the workspace the consolidated dialogs are displayed under ‘Operating Mode’.

• Adjust. Mode
• Meas./Diagram Mode
Switching between the dialog boxes can be done through the navigation bar as well as through the equivalent menu bar. Adjustment changes in the dialog box will be accepted without confirmation. All adjustments are stored when quitting the application and will be loaded when the application gets restarted. The status bar displays current status information of the application

- ‘Ready for use. Sensor connected’
- ‘Sensor disconnected’
- ‘Measure...’
- ‘wait for trigger start event’
- ‘Measure! Wait for trigger stop event’

Furthermore, information from the menu bar and navigation bar through the control elements as well as the storage progress in a CSV-file are indicated in the status bar.

6.1 The Menu Bar/Navigation Bar of the Program

6.1.1 File ➔ Save Measvalue (Shortcut ‘Ctrl+M’)

From here, the measured data of the last measurement are stored in a CSV-file. The output format of the file is adjustable in dialog box ‘Operating Mode ➔ Adjust. Mode ➔ Documentation’ under the headline ‘Output measured values’ (see chapter 6.2.4.1 Documentation ➔ Output Measured Values). In the first column of the CSV-file, the measured values are numbered ascending. The output of columns two to maximal three will be taken over by adjustment ‘Operating Mode ➔ Adjust. Mode ➔ Measure Adjust.’ under the ‘Diagram’ headline. Here, each adjusted physical value will be written into the file. The sequence: [X-Axis], [Y1- Axis], [Y2- Axis]

Caution: all output adjustments must be carried out before the measurement.

Caution: a CSV-file is a text file for the storage of simply structured data. The abbreviation CSV stands for Character Separated Values or Comma Separated Values. These values are separated from each other by special delimiters, e.g. by a comma or a semicolon. A CSV-file can be started by double-click with Excel® (Windows Excel® 2007 - import through data ➔ “from text”). The denotation of list/field/line-ending marks are not explicitly determined. The definitions under 6.2.4.1 Documentation ➔ Output Measured Values ➔ ‘End of line character’ / ‘Column separator’ / ‘Decimal separator’ must possibly be adjusted in INF-USB2 software or in your spreadsheet. For this, see the manual of your spreadsheet.

6.1.2 File ➔ Save Diagram (Shortcut ‘Ctrl+D’)

From here, measured data of the previous measurement can be stored in a BMP-file. Predefined output variables can be adjusted in ‘Operating Mode ➔ Adjust. Mode ➔ Documentation’ under the ‘Output diagram’ headline in box ‘Memory size’. There are following possibilities:

- max:
  Adjustment is only available, if the running system recognizes two monitors. On these two monitors, the diagram is maximum size stretched and stored.
• normal:
The diagram is stretched to approx. screen size and stored.
• min:
The diagram is stretched to approx. 800x600 pixel of the monitor and stored.
• Window:
The diagram gets stored the way it was adjusted by the user.

Any measurement range can be selected by the range slider and the interval slider.

![Diagram](image)

The diagram has a context menu. By right-click on the mouse key, following functions are available:

• Zoom in:
The mouse pointer becomes cross-shaped. By pressing the left mouse key and moving the mouse in the diagram, a rectangle appears which can be zoomed by releasing the mouse key.
• Zoom out:
The diagram indicates the complete range of the previous measurement.
• Scrolling:
The mouse pointer becomes cross-shaped with arrows. By holding the left mouse key in the diagram, the curve can be shifted.
• Grid on/off:
The dashed lines in the diagram form the grid. By this function, the dashed lines can be faded in/out.
• Show legend:
The legend indicates the physical variables and their units. By this function, it can be faded in/out.

Caution: When storing the diagram, only the currently presented part of the measurement will be stored.

6.1.3 File → Print (Shortcut ‘Ctrl+P’)
By this function a print-out (see picture on right) the actual configured diagram, with the printing time and with a configurable headline / comment (under “Additional information → Headline / Comment” at the Documentation dialog) can be adjusted. By this, the headline is shortened to 13 characters and the comment to 30 characters. Supernumerous characters are cut.

6.1.4 File → Exit (Shortcut ‘Ctrl+E’)
Closes the program. If the program is still in the measuring mode while closing, the measurement will be ended. If automatic storage is adjusted (see chapter 0 6.2.4.1 Documentation → Output Measured Values and chapter Error! Reference source not found. Error! Reference source not found.) it will be executed before the program is closed.

6.1.5 Operating Mode
This umbrella term contains all sensor-specific adjustments ‘Adjust. Mode’ as well as the ‘Meas./Diagram Mode’. By selecting a mode it will be displayed in the workspace. Following dialog boxes can be displayed:
• Adjust. Mode → Sensor Connection
• Adjust. Mode → Sensor Information
• Adjust. Mode → Measure Adjust.
• Adjust. Mode → Documentation
• Adjust. Mode → Sensor Adjustment
• Meas./Diagram Mode
When restarting the software it will start with the previous active dialog box. The next menu can be entered via the shortcut ‘Ctrl+TAB’; the previous menu can be entered by ‘Ctrl+Shift+TAB’

6.1.6 View

The control elements under ‘View’ are responsible for fade in/out of bars and displays as well as setting back the windows view. In the menu/navigation bar a checkmark indicates faded in/out bars and displays. The digital displays and the diagram can only be switched in the measuring and diagram mode, otherwise they are grey (disabled). While executing ‘View → Reset Views’ (e.g. via the shortcut ‘Ctrl+R’) the digital displays, the diagram and the main window are set back to original condition.

6.1.7 Language

Here, the language of the INF-USB2 software can be adjusted. All indications of the application are changed in accordance with the selected language. Following languages are supported:
• German
• English
At restart of the software, the previous adjusted language will remain.

6.1.8 Help → Info

Here, the version number of the software is indicated

Help → Advice

Contains the license conditions for this software, the address as well as website and E-mail links.
6.2 Configuration Mode

The configuration mode contains all sensor-, measurement- and documentation adjustments as well as the output of sensor information. The adjustment dialog boxes are presented in the work space through the menu/navigation bar. In the following chapters, the adjustments are introduced and the functions are explained.

6.2.1 Sensor Connection

This software only supports Interface USB devices of the type INF-USB2 or SI-USB. If an Interface USB sensor is connected to a PC, it will be automatically activated by the INF-USB2-VS software. The software can only activate one USB module at a time. The selected sensor gets activated by double-click in one of the displayed lines where the ‘State’ is shown as ‘available’. Sensors in columns with ‘State’ ‘not available’ cannot be activated. ‘not available’ means that the INF-USB2-VS could not open or activate the interface, or that the sensor did not respond. If another process or application takes access on the required interface, this access must be closed. Then search for free interfaces by the ‘Update’ key. The status ‘not available’ indicates Lorenz sensors which are not compatible with this software.

The list indicates further sensor information such as baud rate (115.2 or 230.4 kBaud), address, serial number, final value of the measuring range and sensor type. The final value of the measuring range indicates either the actual nominal value of the channels or the interface type SG, Current, or Voltage. At the two-channel SI-USB, the measuring ranges are presented separated with a virgule (channel A / channel B).

The deactivation of a sensor occurs either by the activation of another sensor or by double-click on the active sensor. When deactivating, the COM interface gets released and can be used by other applications.
6.2.1.1 Sensor Connection ➔ Baud Rate

The changed baud rate is constantly stored in the sensor. This adjustment is also valid for the interplay with other applications.

The maximal adjustable sampling rate is depending on the adjusted baud rate and the used processor of the PC.

6.2.1.2 Sensor Connection ➔ Update

During this update all USB interfaces which are incorporated in the PC will be checked and read-out. Herewith, the baud rate as well as the device address is detected and automatically adjusted. Furthermore the complete sensor data and sensor information will be read-out. The course of the update will be visually presented (see following image)
6.2.2 Sensor Information

This dialog box shows information and characteristics of the activated sensor. The INF-USB2 software reads the data during the sensor activation. If no sensor is activated, all indications are ‘n.a.’ (not available). If the uncertainty of measurement shows ‘n.a.’ it means that the uncertainty of measurement is not stored in the activated sensor. This value can be found on the sensor calibration certificate. The listed value can be stored in the active sensor in menu ‘Sensor Adjustment’ under ‘Store uncertainty of measurement in the sensor’.

Interface sensors have two storage spaces for adjustment values in an unchangeable proprietary block and a changeable user adjustment block. At user adjustment, the condition ‘active’ is also marked with ‘*’, in case this adjustment uses the same factors as the proprietary adjustment. This is the case at subsequent filing of the uncertainty of measurement at active proprietary adjustment.

6.2.2.1 Sensor Information ➔ General

This shows the general information of the connected sensor. Under the headline “Sensor” the sensor designation INF-USB2 with indication of the sensor type (SG, Voltage, Current, Torque, Force, …) is listed in brackets, whereby channel A and channel B are separated by a virgule. Sensor type, serial number, ID, Revision and proprietary calibration are unmodifiable default parameters.

6.2.2.2 Sensor Information ➔ Channel A/B

These fields contain information of the respective measuring channel. In case of the INF-USB2, only channel A is viewable. Channel B is active when an SI-USB module is connected. The serial number can be changed by the user in dialog box ‘Measure Adjust.’ under Measured variable ➔ Display ➔ Serial number. Interface Inc. recommends entering the serial number of the connected sensor.
6.2.3 Measurement Adjust.

In this dialog box all measuring adjustments can be viewed and changed. The measurement adjustments are subdivided into measured variable, diagram and trigger. Except for the serial number, these adjustments will be accepted without confirmation.

The serial number field is secured by a query. The query appears after the first adjustment in the field. The serial number is limited to maximal 6 digits. Possible characters are capital and lower case letters from A-Z as well as numbers from 0 to 9.

The adjustments in **Measured variable**→**Type**, **Measured variable**→**Sampling rate**, **Measured variable**→**Display** and **Measured variable**→**Diagram**→**Reducing the sampling rate by averaging via X values** are sensor related data and get stored in the sensor. Herewith an automatic configuration of the software to the connected sensor is warranted.

When terminating the application the unmentioned values will be stored in the Windows registration under the logged user and restored after restarting the software.

### 6.2.3.1 Measurement Adjustments → Measured variable → Type

This workspace is for the configuration of the measured variables which were recorded by INF-USB2-VS. Before adjusting it must be decided which channels shall be collected. This adjustment is selected accordingly under **Measured variable**→**Type**. After switching, the control elements and their contents will be adapted accordingly in **Measured variable**→**Display**, **Measured variable**→**Diagram**.

**Caution:** Selection of two channels is only possible if an Interface USB device of type 'SI-USB' or 'INF-USB2 with digital input' is connected. At type 'INF-USB2' channel A is a default adjustment and can not be changed.
6.2.3.2 Measurement Adjust. → Measured variable → Sampling Rate

Following measuring/sampling rates are adjustable: 5000/sec, 2500/sec, 1250/sec, 1000/sec, 500/sec, 250/sec, 200/sec, 185/sec, 100/sec, 50/sec, 33/sec, 25/sec, 20/sec, 10/sec, 1/sec, 50/min, 20/min, 10/min, 1/min.

The maximal adjustable sampling rate is depending on the adjusted baud rate and the PC system (see chapter 7.2.1.1 sensor connection → baud rate).

6.2.3.3 Measurement Adjust. → Measured variable → Display

The configuration view differs depending on the connected device. At the INF-USB2 only one channel will be displayed.

The adjustments under ‘Measured variable→Display’ decide on the output and display of the respective channel. Hereby the number of decimal places, the unit, a running averaging and the leading sign can be configured from a selection. Furthermore a custom serial number can be assigned to each channel.

Up to four decimal places can be indicated for every physical size. This adjustment is considered in the digital displays, in the diagram and in the readout of the CSV-file. For the adjustment of the unit of a physical size, German, English and American units can be selected. The selection is dependent on the type class of the connected device. The conversion onto the adjusted unit is automatically carried out by the software. Under “Scaling” the additionally defined unit is shown in square brackets. A running average can be formed for each physical size of 1 to 512 values. The leading sign of the channel is predefined in the sensor and through the adjustment ‘Measured variable→Display→Sign’ it can be changed.

Key ‘Change’ under Scaling opens a dialog which allows scaling as well as the definition of an additional unit. In the choice box ‘Measured variable→Display→Unit’, the additional unit is marked with square brackets.

### CAUTION!
Using the “Read actually Measvalue” box assumes a 0.00mv output from the sensor at zero load. This will result in an error equal to the actual zero balance of the sensor. For example, if the sensor has a 1% zero offset, a 1% error will result. For scaling using a known weight, please refer to Quick Start Guide available for download on the PDFs/Downloads tab at www.infusb2.interfaceforce.com.

In dialog ‘Scaling Change’ the input variable (see previous image ‘Scaling Change’ under headline ‘Measure Adjust.’) can be scaled with an arbitrary unit. The ‘Sensor adjustment’ displays the defined proprietary calibration and/or the user adjustment of the channel. In the image channel A with the input variable force which reads out 25000 ADU at 10.0 kN nominal value was selected. A readjustment of these values can be carried out through the input boxes in Scaling. In the left input box either a certain force value can be entered or the actual measured value of the sensor can be read. In the middle input box the new output value which corresponds to the input value of the left box must be entered. In the right input

3 If no scaling was stored, ‘Create’ will appear instead of ‘Change’ and the selection in the unit box is limited to the device type without an additional unit.
box a unit with a maximum length of 5 digits can be entered. By pressing the “Change” button these inputs will be stored in the sensor.

Caution: The closer the scaling value to the final value of the sensor, the more precisely is the display of the measured value during the measurement.

6.2.3.4 Measure Adjust. → Diagram

In input box ‘Reducing the sampling rate by averaging via X values.’ it is possible to decrease the measuring points which should be saved by entering a value for \( X \). Hence, the adjusted sampling rate e.g. 200/sec at \( X=10 \) will be reduced to 20 displayed values in the diagram. This is also valid for storing the measured values in a file. When reducing the sampling rate, an averaging over the last \( X \) values is carried out.

The adjustment ‘Reducing the sampling rate by averaging via X values.’ has no effect on the represented values in the digital displays.

The adjustments under → Average of the individual physical sizes and the adjustment ‘Reducing the sampling rate by averaging via X values.’ act cumulatively.

During the update of the diagram during an ongoing measurement, the complete measurement is represented at a resultant sampling rate less than or equal to 20 measurements/sec. At sampling rates above 20 measurements/sec, only the last 5 seconds of the measurement are represented. After the termination of the measurement, the complete measurement is always shown in the diagram.

The adjustment of this configuration should be started with the X-axis. Resulting from the adjustment of the X-axis, the application updates the number of Y-axis as well as their selectable contents. All combinations of measuring variables can be represented in a diagram.

Caution: The measured values are written in a CSV-file with the adjusted channels. The writing sequence is: [X-axis], [Y1-Achse], [Y2-axis]. If a Y-axis is not required, it is also possible to set them to “Off”. Nevertheless, the application assures that minimum one variable on the Y-axis has not been set to “Off”.
6.2.3.5 Measure Adjust. → Trigger

Course:
1. Select a start event.
2. Select a stop event.
3. Enter trigger key.
4. Actuate a trigger start event.
5. Actuate a trigger stop event.
6. Measurement recorded
In the previous signal flowchart, the general course of measurement by means of a triggering is described. The activation button ‘Trigger’ can be found in the ‘Meas./Diagram Mode’ under ‘Measure Stop’. The software triggering consists of two events which are adjustable according the requirements as follows:

- **Trigger start → Source:**
  - **Off/Measure Start:**
    Entering ‘Measure Start’ releases the Trigger start event. (The function to start an event can also be entered in the following sources).
  - **Channel A / Channel B:**
    See chapter 6.2.3.5.1 Trigger.
  - **System time:**
    The application shows an input box where the date and the time of the measurement start can be adjusted. The adjustment is limited to the current time plus 15 seconds. These values must be re-adjusted after each measurement; otherwise the following measurement will start immediately by pressing the trigger, because the previously adjusted time lies in the past.

- **Trigger stop → Source:**
  - **Off/Measure Stop:**
    Entering ‘Measure Stop’ releases the Trigger stop event. (The function to stop an event can also be entered in the following sources).
  - **Channel A / Channel B:**
    See chapter 6.2.3.5.1 Trigger.
  - **Measurement duration:**
    For this selection an input box is available. The time unit (seconds, minutes) is taken from the sampling rate. The number of measurements is calculated and displayed by the application next to the input box.
  - **Number of measurements:**
    For this selection, an input box is available to indicate the number of measuring points. The measurement duration is displayed and calculated next to the input box. The time unit (seconds, minutes) is taken from the sampling rate.

**Remark:** The source adjustments of trigger start and trigger stop can be optionally combined with each other.

**Remark:** The adjustments “Measurement duration” and “Number of measurements” refer to the adjusted sampling rate and not to the reduction of the sampling rate.

### 6.2.3.5.1 Trigger

The picture on the following page shows an example of how a measurement by means of triggering can be recorded to a physical variable. At excess, the hysteresis value will be deducted from the threshold and at under-run it will be added. The hysteresis calculation for each possible physical size is shown under the example diagram on the next page. At this triggering not only the value of threshold (Y\textsubscript{over}, Z\textsubscript{over}) of a physical variable, but also a direction must be indicated. In the example diagram, the direction ‘over run’ is triggered. This means that the measured value must fall below the hysteresis value before the trigger will react to the over run of the value of threshold. On the opposite, the adjustment ‘under run’ means that the measured value must exceed the hysteresis value before the trigger reacts to the under run of the value of threshold. The grey-framed area of the example diagram equals the display in the diagram of the INF-USB2-VS after the measurement course. This area can be stored in a CSV-file.

- Y\textsubscript{over} = Trigger start value of a physical variable with directional adjustment ‘over run’
- Z\textsubscript{over} = Trigger stop value of a physical variable with directional adjustment ‘under run’

At over run, the value of the hysteresis is deducted from the value of threshold; when below, it will be added. The calculation of hysteresis for each possible physical variable is shown beneath the example diagram on the next page.
6.2.3.5.2 Diagram Example

Channel A / Channel B

The size of the hysteresis is 1% of the indicated nominal value of the connected sensor. Except for type classes SG, Current and Voltage the hysteresis will be scaled to maximal 1% of the input value because normally the nominal value is not known.

6.2.4 Documentation
Here, the user can carry out documentation configuration. The adjustments refer to the storage of measurements as BMP and/or CSV-file.

6.2.4.1 Documentation → Output Measured Values

- **Automatic storage:**
  The storage of the measured value into an output file can occur automatically by the software. Three adjustment possibilities are selectable for this:
  - **None:** The automatic storage is disabled.
  - **Save all measurements into one file:** This option files each measurement in the same CSV-file at the end. The name from the prefix field is used as the file name. The file gets stored in the registered target directory.
  - **Save each measurement with an own index:** This option creates a separate CSV-file at the end of each measurement. The file name consists of the prefix and the index YYYYMMDDHHmss#### (####' number beginning with leading zeros 0000; 0001; ...)

  The path length is limited by the running system

- **Remark:** Definition "Measurement" see chapter 6.1.1 File → Save Measvalue (Shortcut 'Ctrl+M')

- **Target directory:**
  The target path is registered under ‘Target directory’ (Standard adjustment ..\<user name>\My Documents\INF-USB2-VS). Instead of this, you can click on the folder and select a directory.

- **Prefix:**
  Please enter the file name which is used for the automatic storage in this input box. (Further details about file name/prefix can be found under headline "Automatic Storage").

- **End of line character:**
  The desired line ending mark for the output in a file gets adjusted in this box.
  Following possibilities can be selected:
  - **CRLF** - Carriage Return / Line Feed - Carriage return line feed (MS-DOS, Windows)
  - **LFCR** - Line Feed / Carriage Return - Line feed carriage return (Linux Console)
  - **CR** - Carriage Return - Carriage return (Apple II, Apple Mac OS up to Version 9)
  - **LF** - Line Feed - Line feed (Unix-Derivate, Mac OS X)

- **Column separator:**
  The column delimiter will be read out at the first execution of the application from Windows system control (country selection) and will be set accordingly. At each further restart of the application, the previously adjusted delimiter will be used. Following selection is possible in this box:
  - **TAB** - Tabulator
  - **;** - Semicolon
  - **,** - Comma
  - **.** - Point
  - **Space** - Space Caracter

- **Decimal separator:**
  The decimal delimiter is carried out the same way as described for the column separator. Following selection is possible in this box:
  - **,** - Comma
  - **.** - Point

  Remark: Supplementary changes of the country adjustments in the operating system have no influence on the once adjusted values of this software.

- **Additional information show / hide:**
  In this group, checkmarks can be placed to add further information to the output of measured values. The entries in the three entry boxes ‘Headline’, ‘Address’, and ‘Comment’ can be specified arbitrarily. With the checkmark, these entries will be recorded in the output file. The ‘Uncertainty of
measurement' - if the connected sensor has one - can also be displayed in the output file. By a checkmark in ‘Date / Time’ the measurement period can also be recorded in the output file. By a checkmark in ‘Physical unit’ it is also possible to systematically fade in/out the physical units in the output file.

6.2.4.2 Documentation → Output Diagram

Automatic storage:
The software can automatically store the diagram in an output file. For this, two adjustment possibilities are available:

• **None**: the automatic storage is disabled.
• **Save any diagram with an own index**: this option creates a separate BMP-file at the end of each measurement. The file name is a combination of the prefix and the index YYYYMMTTHHmmss#### ('####' number beginning with leading zeros 0000; 0001; ... ).

The path length is limited by the running system.

**Remark**: Definition “Measurement” see chapter 6.1.2 File → Save Diagram (Shortcut ‘Ctrl+D’)

• **Target directory**:
The target path is registered in ‘Target directory’ (standard adjustment ..\<user name>\my documents\INF-USB2-VS). Instead of this, you can click on the folder and select a directory.

• **Prefix**:
Enter the file name which shall be used for the automatic storage in this input box (further details regarding file name/prefix can be found under the headline ‘Automatic storage’).

• **Memory Size**:

6.2.4.3 Documentation → Additional Information

Here is free text which can be activated in ‘Documentation → Output measured values → Additional information show / hide’.
6.2.5 Sensor Adjustment

In this dialog, the uncertainty of measurement in % can be stored in the connected sensor. This variable - if available - shows the application in the 'Meas./Diagram Mode' and in the 'Sensor Information' dialog. The uncertainty of measurement can also be read out in a CSV output file (see chapter 0

6.2.4.1 Documentation → Output Measured Values).

- **Store uncertainty of measurement in the sensor:**
  This function allows to store a maximum value for the uncertainty of measurement in the sensor. This value is usually determined at a proprietary or DKD calibration. If the proprietary adjustment of the connected sensor is active and if a value for the uncertainty of measurement was indicated, it means that the sensor had a proprietary or a DKD calibration at Interface Inc. Permissible values for the uncertainty of measurement are [5 % > uncertainty of measurement > 0 %]. If the sensor is connected, this value will be displayed in the 'Meas./Diagram Mode', in the 'Sensor Information' and if required in the CSV-output file. This value is only for documentation purposes and has no influence on the measured values.
6.3 Meas./Diagram Mode

In the ‘Meas./Diagram Mode’ the digital displays of the physical variables and the diagram can be activated. Only the displays which were check-marked in ‘Measure Adjust. → Measured variable → Type’ are active.

Each, the digital displays and the diagram are in an independent window. These windows can be positioned to the main window or they can freely be placed on the monitor. In order to scroll the windows, the mouse pointer must be placed on the title bar of the respective window. By keeping the left mouse key pressed, the window can be shifted or positioned. The contents of the window automatically adopts to the window size. By key ‘Ctrl’ the positioning in the main window can be avoided.

Due to system-relevant restrictions under operating systems Windows 2000 and Windows XP it is not possible to draw the diagram out of the main window of the application. Also, with these operating systems, the application cannot be placed outside of the monitor. When trying, it will always jump back to the visible workspace.

Each digital display has four output fields. One each for the current measured value, the tared value, the minimum value and the maximum value. The minimum and maximum value can be set back by the buttons ‘MIN Reset’ and ‘MAX Reset’. If the tare-button shows ‘TARE’ and is kept pressed, this will set the current measured value to zero and the tared difference will be displayed above in the output field. Afterwards this button indicates ‘TARE=0’, thus the tare can be abrogated.

Measure Start:
With this button, a measurement gets started. The digital displays and the diagram will be fed with measured values after pressing this button. Unnecessary keys are deactivated during the measurement. Also, the status of the application “Measuring…” is indicated in the status bar.

Software trigger start event
**Measure Stop:**
Can only be used at active measurement. As soon as the key was pressed, the measurement will be stopped and will initiate possible automatic storage. At active automatic storage into a file, the progress is shown on the status bar as well as the idle state 'Ready for use. Sensor connected'.

→ Software trigger stop event

**Trigger:**
This key activates a software triggering as explained in chapter 6.2.3.5. The status lamp on the side of the key blinks yellow at active triggering. By pressing again, the triggering will be deactivated.

<table>
<thead>
<tr>
<th>Trigger LED</th>
<th>Condition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Grey</td>
<td>Trigger OFF</td>
</tr>
<tr>
<td>Flashing Yellow</td>
<td>Trigger waits for a trigger start event. Only the digital displays are updated.</td>
</tr>
<tr>
<td>Green</td>
<td>Trigger Measurements ON. Digital displays and diagram are updated with values.</td>
</tr>
</tbody>
</table>

By a check mark, the trigger gets reactivated as soon as all actions of the Trigger-Stop-Event are processed (e.g. write file. See chapter 6.2.4.1 Documentation → Output Measured Values

Activate only if an automatic storage from 6.2.4.1 or 6.2.4.2 is active.

**Single Measurement:**
With this key, a single current measured value gets requested from the active sensor. This function can only be carried out in the idle mode/measuring stop of the application.

**Control:**
The button ‘Control’ is only activated during the measurement at low sampling rates (<20/sec) and in idle mode.

By means of the control, the measuring bridge in the sensor gets detuned and issues the nominal range. A red lamp next to the button indicates active control. By clicking on ‘Control’ again, it will be deactivated.
## 7 Debugging

This chart helps to find frequent errors and the measures for debugging.

<table>
<thead>
<tr>
<th>Error</th>
<th>Possible Cause</th>
<th>Debugging</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application does not start</td>
<td>WIN98 or older versions are used</td>
<td>Required operating system: WIN 2000; WIN XP; WIN VISTA, WIN 7</td>
</tr>
<tr>
<td></td>
<td>No drivers for USB sensors</td>
<td>Install the driver packet from the product CD. Install drivers with administrator rights only.</td>
</tr>
<tr>
<td></td>
<td>Sensor is not connected to the PC</td>
<td>Connect sensor to the PC</td>
</tr>
<tr>
<td>Sensor is connected to the PC but the application won't start or no communication available.</td>
<td>Driver problems or misfeature of the USB connection</td>
<td>Terminate the application. Unplug the USB-connection between sensor and PC and reconnect it</td>
</tr>
<tr>
<td>A connection to the INF-USB2 Or SI-USB is not possible.</td>
<td>Driver not or incorrectly installed.</td>
<td>Install driver package. The first start-up of the INF-USB2 or SI-USB must be carried out with administrator rights.</td>
</tr>
<tr>
<td></td>
<td>Supply voltage is overstrained in such a way that it breaks down.</td>
<td>Check whether the connected sensor corresponds to the specifications. If the sensor requires higher current than available for the INF-USB2 or SI-USB then this sensor cannot be used.</td>
</tr>
<tr>
<td></td>
<td>Supply voltage is shortened.</td>
<td>Fix the short circuit.</td>
</tr>
<tr>
<td>Output signal remains at the positive or negative display stop device/dead stop.</td>
<td>Active-Sensor or Current-Sensor connected to SG input.</td>
<td>Check on type label which input type has been configured for the applied sensor connection.</td>
</tr>
<tr>
<td></td>
<td>Supply voltage connected to sensor input.</td>
<td>Check/correct the pin assignment</td>
</tr>
<tr>
<td>Output signal highly fluctuates (SG)</td>
<td>Open sensor input.</td>
<td>Connect sensor</td>
</tr>
</tbody>
</table>